Recent Posts

Pages: [1] 2 3 ... 10
1
Troubleshooting / Help / Re: RMXP Skill Tree System Error
« Last post by KK20 on Today at 08:37:46 AM »
The error is because you don't have a skill tree defined for actor ID 3 (more specifically, SKILLS_ROWS has no entry at index 3 within the array). I take it he's in your "party reserve" since you do have a Party Switcher script. Not sure why this line gets called though.
2
Troubleshooting / Help / RMXP Skill Tree System Error
« Last post by CriticalHit on Today at 05:55:21 AM »
Hi,

I keep getting an error with my current project. The project is using a somewhat modified version of the default battle system. You can find my project here: 
https://github.com/antlaw0/RMXP-S.T.A.R-Game
This is the error I get regularly, starting game in starting map, winning a battle, etc:
Script 'Skill Tree' error line 773 noMethodError occured. Undefined method 'size' for nil:NilClass

How can I fix this issue? What is going wrong?

Thanks to anyone who can help.
3
Resource Database / Re: Pandora's Box (MASSIVE Resource Collection)
« Last post by KK20 on November 20, 2017, 07:01:45 AM »
Are you using these resources with something other than RMXP? Because that's what they were designed for.
4
Resource Database / Re: Pandora's Box (MASSIVE Resource Collection)
« Last post by robco on November 20, 2017, 05:11:20 AM »
yes... How to fucking instal maybe?  :<_<:
The stuff should be pack in an exe no matter the size. One day of downloading is worthy, this will take days now... maybe more... :facepalm:

I have issues importing the files now. The imported files are cut.  (fix here: https://forums.rpgmakerweb.com/index.php?threads/tilesets-get-cut-when-importing.70050/)
Basically I have to cut the packed files into tiny pieces.. will take weeks maybe months maybe... more...

This is important i just lost 4 hours for nothing, put the bugs fixes in a "read me" and reup everything once im done checking bugs (should be done years and years ago).

To be clear I am hellish mad at ENTERBRAIN who obviously makes the importing issues to sell their own worthless trashes. The website is great, i like it.

Let's try to download 2012's RPGM and hope everything will be fixed so.
5
Script order conflict.
You need to put Ccoa UMS above Blizz-ABS but below Custom Resolution.

Reason was due to Ccoa UMS rewriting Interpreter#execute_command rather than aliasing it.
6
im so sorry for making so many issues but somehow the script just messes up so many things in my game.... some pictures dont show up and i cant access another location. it should transfer the player when you click on the edge of the screen but it doesnt. and the little 'tutorial' pictures are supposed to erase themself and they dont/
https://drive.google.com/drive/folders/1wjfwZf8-BAQFK70oGuXdxQuxciAqdoPP?usp=sharing here are two versions of the game, one of them with one of them without the script. after deleting the script everythign goes back to normal

i reall dont want to make so many problems so if im being a trouble i thought about just deleting the script, hiding the text box, and then just showing both the text box and the dialogue head as 'show image'. but for that i would have to know how to do the text aligment to push it further. and of that im not sure when it comes to all the scripts i got.
7
Regarding moving textbox position, that was because you have Blizz-ABS installed. It technically thinks you are in battle since the script is designed for on-map battles. Refer to this line in Ccoa UMS (around line 1326):
Code: [Select]
    if $game_temp.in_battle
      self.y = 16
    else
It was setting the message window close to the top of the screen because of this. If we change it to this:
Code: [Select]
    if $BlizzABS.nil? && $game_temp.in_battle
      self.y = 16
    else
you should be good.

Regarding message window dimensions, you can change this yourself in the script or through script calls in-game. In the script, you can find these instance variables and change their values accordingly:
Code: [Select]
    @window_height = 128
    @window_width = 480
In-game, you can change them using the two script calls:
Code: [Select]
$game_system.window_height = 150
$game_system.window_width = 600
or directly in messages:
Code: [Select]
\height[150]\width[600]This is a text message in a new window size
8
Projects / Games / Re: Legends of Astravia
« Last post by BoisterousHero on November 17, 2017, 10:21:41 PM »
An actually good demo with more than 10 minutes of gameplay coming soon. Stay tuned.

Here are a few more screenshots:
(click to show/hide)
(click to show/hide)

And some of the main characters you'll get to play as:
(click to show/hide)

More info on the features/gameplay to come:
https://boisteroushero.itch.io/legends-of-astravia/devlog/14568/post-igmc2017-jam-update
9
Send me your Scripts.rxdata
10
https://youtu.be/dpn24Td60-0 this is the issue im having now. i swear those scripts just hate me
The first text is something that happens automatically when entering this map so it looks weird since i just dropped the character there but its ok. What i dont know is why those textboxes are jumping around like that. i did everything like in the demo, i also tried editing the demo and it worked there
also somehow the textbox got smaller? like it cant fit all the letters into it as you can see with the 'a few mo ago'
Pages: [1] 2 3 ... 10