[Solved] Can't Transfer between maps Blizz ABS

Started by CriticalHit, July 26, 2019, 08:19:37 pm

Previous topic - Next topic


July 26, 2019, 08:19:37 pm Last Edit: July 28, 2019, 12:49:17 pm by CriticalHit
I am using RMXP with Blizz ABS. For some reason, I cannot change maps. I activate an event that has the transfer player command and nothing happens. I have isolated the issue to the Blizz ABS scripts as I have removed all three parts and transferring works fine. If I use the transfer player command on a parallel process, it works for what that is worth. I am stumped as to the cause and would greatly appreciate any help in resolving this issue.

Here is the repository with the project that has this issue:


Thank you


The problem is the UMS overrides Interpreter.execute_command without calling the original method.  BlizzABS uses an alias on this method to temporarily set the $game_temp.in_battle flag to false while running commands, but the UMS stops that from happening.  Try moving the UMS above BlizzABS in your script order.


Thank you, that solved it. This is my first time using the UMS so I am not that familiar with it yet.