Chaos Project

RPG Maker => RPG Maker Scripts => Script Troubleshooting => Topic started by: kennetha123 on August 08, 2014, 03:44:00 am

Title: The Server cannot run[SOLVED]
Post by: kennetha123 on August 08, 2014, 03:44:00 am
Hello , i am new in this RMX-OS and using RPG maker VX ace for 2 years. when i found the XP could make
an mmorpg/online system , i'm very grateful. but after 4 days trying and do some learn about mysql and the server, it come to a point i can't figure out what happened.
my server always do restart but i can't understand what the main problem.
here the server:

>Starting TCP Server at '192.168.1.6:54269'...
>Connecting to MySQL database 'rmxosdb'...
Unexpected error occured!
undefined method 'synchronize' for nil:NilClass
src/SQL.rb:41:in 'optimize_databse'
src/SQL.rb:25:in 'initialize'
src/Server.rb:81:in 'new'
src/Server.rb:81:in 'connect_to_database'
src/Server.rb:55:in 'start'
./RMX-OS.rb:108:in 'main'
C:/Program Files/Enterbrain/RMX-OS/Server/RMX-OS.rb:268:in '<main>'

RMX-OS Server is being terminated...
Restart in: 5 4 3 2 1

and this my copy of cfg.ini file:

NAME = 'RMX-OS Server'
HOST = '192.168.1.6'
PORT = 54269
GAME_VERSION = 1.0

DEBUG_MODE = false
LOG_MESSAGES = false
LOG_ERRORS = true
LOG_ACTIONS = true

MAXIMUM_CONNECTIONS = 50
LOGIN_TIMEOUT = 30
AUTO_RESTART = true
RESTART_TIME = 5
USE_IP_BANNING = true
RUBY_PROMPT = true
EXTENDED_THREADING = true
OPTIMIZE_DATABASE_ON_STARTUP = true

SQL_HOSTNAME = '127.0.0.1'
SQL_USERNAME = 'root'
SQL_PASSWORD = 'mysql'
SQL_DATABASE = 'rmxosdb'

INBOX_SIZE = 20

EXTENSIONS = [
]

please help me to figure out what happened . sorry if this was a noob question.
ty sir ^^

I use RPG maker XP and using Windows 7 Professional 32bit
Title: Re: The Server cannot run
Post by: PhoenixFire on August 08, 2014, 07:07:34 am
You checked to make sure you have MySQL installed correctly? If you use mySQL Workbench, are you able to connect to the local database using that tool? You've double-checked your settings (port number, password, etc)? Have you tried removing the database password, or connecting as a different user with no password?


Try the following:
NAME = 'RMX-OS Server'
HOST = '127.0.0.1'
PORT = 54269
GAME_VERSION = 1.0

DEBUG_MODE = false
LOG_MESSAGES = false
LOG_ERRORS = true
LOG_ACTIONS = true

MAXIMUM_CONNECTIONS = 50
LOGIN_TIMEOUT = 30
AUTO_RESTART = true
RESTART_TIME = 5
USE_IP_BANNING = true
RUBY_PROMPT = true
EXTENDED_THREADING = true
OPTIMIZE_DATABASE_ON_STARTUP = true

SQL_HOSTNAME = '127.0.0.1'
SQL_USERNAME = 'root'
SQL_PASSWORD = 'mysql'
SQL_DATABASE = 'rmxosdb'

INBOX_SIZE = 20

EXTENSIONS = [
]
Title: Re: The Server cannot run[SOLVED]
Post by: kennetha123 on August 08, 2014, 10:59:11 am
Well i have check all those for all day long about 2 days.
But i hav solved it , by reinstalling the RMX-OS , the server work fine.

i think the problem is the ip. i use the localhost and it work smoothly.
Title: Re: The Server cannot run[SOLVED]
Post by: chaucer on August 08, 2014, 11:26:36 am
Quote from: kennetha123 on August 08, 2014, 03:44:00 am

and this my copy of cfg.ini file:

NAME = 'RMX-OS Server'
HOST = '192.168.1.6'
PORT = 54269
GAME_VERSION = 1.0

DEBUG_MODE = false
LOG_MESSAGES = false
LOG_ERRORS = true
LOG_ACTIONS = true

MAXIMUM_CONNECTIONS = 50
LOGIN_TIMEOUT = 30
AUTO_RESTART = true
RESTART_TIME = 5
USE_IP_BANNING = true
RUBY_PROMPT = true
EXTENDED_THREADING = true
OPTIMIZE_DATABASE_ON_STARTUP = true

SQL_HOSTNAME = '127.0.0.1'
SQL_USERNAME = 'root'
SQL_PASSWORD = 'mysql'
SQL_DATABASE = 'rmxosdb'

INBOX_SIZE = 20

EXTENSIONS = [
]

forgot to change that.
edit: bit too late I guess : P