[XP] RMXPAce -- Using the VX Ace engine in your XP games

Started by Terv, February 17, 2013, 04:38:51 pm

Previous topic - Next topic

LiTTleDRAgo

using Me(tm)'s Tilemap = glitch, the map become weird if player moves
using F0's Tilemap = superclass missmatch and other undefined method
using King's Tilemap = everytime I go to menu and back to Scene_Map, the autotile is gone
using Seph's Tilemap = Lag as hell

Terv

Me's rewrite is the only one incompatible with smooth scrolling scripts which is causing graphical glitches. Other than that it is highly compatible.
Delete or rename the Plane part in F0's script, it will work then. Btw, does anyone know a workaround for those errors?
Could you upload a sample project for the bug in King's rewrite? It's still a wip and he's interested in improving it.
I wonder why Seph's script is lagging for you, I have tested it on huge maps with even more huge tilesets. But anyway, it's known for causing problems.

Go for Zero's rewrite, that one should do the job no matter how complex your.project is.

LiTTleDRAgo

about king's, it seems that problem only occured if Scene_(something) (other than Scene_Map) is using Spriteset_Map.new to make a translucent effect

about F0's script, I somehow can use it but now some of things didn't show properly as I intended

Spoiler: ShowHide

Terv

I just checked it in the demo and it's a general bug in Zer0's rewrite that affects partially transparent animated autotiles only.
I've created a ticket over here, let's see if someone can track down the reason :/

KK20

Solution has been posted. :-*

If you are also having issues with displaying tiles on layers above autotiles, I've posted a solution to that as well in the Custom Resolution topic.

Other Projects
RPG Maker XP Ace  Upgrade RMXP to RMVXA performance!
XPA Tilemap  Tilemap rewrite with many features, including custom resolution!

Nintendo Switch Friend Code: 8310-1917-5318
Discord: KK20 Tyler#8901

Join the CP Discord Server!

Terv

Good news: Thanks to Blizzard I found a universal fix for the superclass mismatch error, which means that Blizz-ABS is working now, and boy it runs great :haha:

Check out the page on the bugtracker for the solution.

Blizzard

Lol, we already knew that solution at ARC: http://forum.chaos-project.com/index.php/topic,9665.msg144686.html#msg144686
But it wasn't enough for us so we fixed the Ruby source code instead.
Check out Daygames and our games:

King of Booze 2      King of Booze: Never Ever
Drinking Game for Android      Never have I ever for Android
Drinking Game for iOS      Never have I ever for iOS


Quote from: winkioI do not speak to bricks, either as individuals or in wall form.

Quote from: Barney StinsonWhen I get sad, I stop being sad and be awesome instead. True story.

Terv

Ironically I stumble upon that thread like 4 weeks ago and it was linked everywhere but no one (including me) seemed to actually read the answers :facepalm:

Blizzard

I know. I remember linking to that thread just a few weeks ago. xD
Check out Daygames and our games:

King of Booze 2      King of Booze: Never Ever
Drinking Game for Android      Never have I ever for Android
Drinking Game for iOS      Never have I ever for iOS


Quote from: winkioI do not speak to bricks, either as individuals or in wall form.

Quote from: Barney StinsonWhen I get sad, I stop being sad and be awesome instead. True story.

exile360

Oh. Emm. Gee! This is simply epic.

I had a go with it and eventually got my project (which uses RMXOS) to work! Localhost though, can't confirm whether or not I have the same issue as the rest of RMX-OS users in this thread. It looks insanely good and runs silky smooth. <3 Quite sad that I won't be able to use it, because it knocks out almost half of my scripts, haha. :P Didn't expect that many incompatibility issues when I was reading the thread, but my game is pretty script-heavy, so it's natural I suppose. I can post them in the bugtracker but it'll be a lot of work to ask for. The scripts that I've found not to be working this far are:


  • RTAB

  • TONS of Addons

  • MOG Scene Shop

  • LegACy CMS

  • Multiple Message Windows

  • Blizz's Event Anti-Lag

  • KK20 Quest Log


and possibly more...

Should I post them in the bugtracker with respective errors?

Keep up the good work! This is pretty amazing overall. :)

Terv

It'd be nice if you could post some reports of your most popular scripts, like the Mog menu and KK20's quest log. Generally speaking everything menu-related is mostly easy to fix. You can also send them to me via PM if you don't want to create an account.
Actually both most recent versions (7.62b+7.63b) of Tons of Addons seem to run quite well for me. But that doesn't help you at all as long as RMX-OS is broken :(

Btw, we've got some really script-heavy projects to work on the German forums (including mine) but the debugging can indeed be quite time consuming due to the often random nature of the errors.

exile360

Quite strange that TONS doesn't work for me then, I had to remove it from the project to get my game to launch. But I'll try to add some reports, hopefully later today. :)

Shining Riku

Hmm. I have no idea what the problem is, but I've used this tutorial to upgrade one of my projects and got the error: "the specified procedure could not be found"

I'm 99% certain I followed all of the steps, and have tried this in a full project, and then a few times in the same project minus all of its scripts (pretty much a New Project at that point)

Do you have any idea what might cause something like this? o.O
In the meantime I'll fiddle around more. I should probably add this to the bug logger...If only there were more I could offer to give insight into this problem in the first place! Guh!

It literally tells me nothing more than this.

Terv

Make sure the Library set in Game.ini matches the name of the .dll in your folder.
In case it doesn't, rename the RGSS301.dll instead of changing the ini.

Quote3.2 Insert the Engine
[...] Open your Game.ini and see what is written behind Library=. Rename RGSS301.dll accordingly (in most cases RGSS102E.dll).

G_G

I discovered how to launch the RGSS3 player into Console and Test mode. All you have to do is launch Game.exe from a batch script or command line.

Game.exe test console


Place that in a .bat file, and run the file whenever you need to playtest your game. $TEST will be true and the console window will show up. You can also use a Batch2Exe converter, convert the batch script to an EXE and rename it to "Game.exe". Then rename Game.exe, Game.ini to something else (Like RealGame) and you can launch the batch script from the editor. Leave Game.rxproj as it is. In fact, I'll post an example project after its all setup.

Spoiler: ShowHide


You can also replace this line:
$DEBUG = $TEST = true

With this line:
$DEBUG = $TEST


EDIT: Here's the demo project. Just open Game.rxproj and run the game from the editor. $DEBUG and $TEST will be true and the console will appear. This includes all Audio, Graphics, fonts, etc... This is the whole works.

https://www.box.com/s/dty8mrl1esf1k6u32k65

EDIT 2:

Found a better way to setup the batch script.
if "%~1"=="debug" (
RealGame.exe test console
) else (
RealGame.exe
)


Convert that to an Exe and place it as Game.exe in your project. Be sure to rename your real game and real ini to "RealGame".

Spoofus

This may sound dumb, but let me get this straight, If you do all that is required to do this, You don't have to make edits to your existing scripts? and this will alow the game to run smoother, and all this runs in RMXP but using the benefits of VXace?


My Blog site I am working on: http://spoofus.weebly.com/

KK20

It's mainly to use Ruby 1.9.2 versus 1.8.1 in your RMXP games. You might have to make edits to some of your scripts because of the version changes, but it shouldn't be a terribly large amount.

Other Projects
RPG Maker XP Ace  Upgrade RMXP to RMVXA performance!
XPA Tilemap  Tilemap rewrite with many features, including custom resolution!

Nintendo Switch Friend Code: 8310-1917-5318
Discord: KK20 Tyler#8901

Join the CP Discord Server!

Spoofus

Okay, I was curious after coming across this topic.
Time to see what changes that need to be made for this then, I am very curious about this now.



My Blog site I am working on: http://spoofus.weebly.com/

Terv

I just finished migrating the bugtracker to a new and sleek Stack Exchange like system, pruning 9,700 inactive users along the way (:facepalm:). It's now got all the features there should have been from the very beginning, including posting without registration and email notifications for just about everything.

In case you are one of the few exalted registered users you'll have to request a new password now in order to access your account. This is due to a database change from MD5 password hashes to salted SHA1 hashes.

WhiteRose

This is incredible. Thank you so much for the tutorial - it's definitely something that I'll be using in the future. (I know I'm a little late on the thank-you train, but I've been gone, so I thought I'd mention it. :) )