[XP][VX][VXA] Simple Event Sensor

Started by LiTTleDRAgo, February 21, 2011, 07:41:25 am

Previous topic - Next topic

LiTTleDRAgo

February 21, 2011, 07:41:25 am Last Edit: April 27, 2012, 12:22:47 am by LiTTleDRAgo
Simple Event Sensor
Authors: LiTTleDRAgo
Version: 1.10
Type: Add-on
Key Term: Misc Add-on



Introduction

It's simple, if your character's distance with an event, that event self switch will turned on


Features


  • Event Sensor




Screenshots




Demo

If requested


Script

Here


Instructions

Set the event name to : <Sensor(RANGE)>
example :
           <Sensor4>

If player is in event sensor range, Self switch D (default) will turned ON


Compatibility

Should compatible with anything


Credits and Thanks


  • LiTTleDRAgo




Author's Notes

It's just a simple script, I'm not sure if I should apply the template or not

Enjoy ~

G_G

Suggestion. Add a \dswitch tag for event names. and a \drange tag. Again this way it won't do it for all events. I can easily see someone using the "D" switch in a autorun event or something, then the player gets close to it and bam, problems all over.
\dswitch (detect switch)
\drange (detect range)

nathmatt

Join Dead Frontier
Sorry, I will no longer be scripting for RMXP. I may or may not give support for my scripts. I don't have the will to script in RGSS anymore.
My script


SBR*


LiTTleDRAgo

update screenshot, configuration, and cross engined

Kiwa

April 17, 2014, 04:16:28 am #5 Last Edit: April 17, 2014, 04:26:39 am by Kiwa
Does this sensor not work with the "List of event commands" ? on the right side of the Edit Event window?

Its just that i couldn't get it to work with anything other than the autonomous movements.
i couldn't execute event commands with parallel process, autorun, player touch, ect...
I tried interacting directly with the event by making it have a text box pop up but it wouldn't let me interact at all. it was on its own mission all alone lol.

KK20






   


   
   


   
   

Other Projects
RPG Maker XP AceUpgrade RMXP to RMVXA performance!
XPA TilemapTilemap rewrite with many features, including custom resolution!



Nintendo Switch Friend Code: 8310-1917-5318
Discord: KK20 Tyler#8901

Join the CP Discord Server!

Kiwa

I'm really not sure what I was doing wrong.. i must be eventing it wrong. I'll Give heretics a run tomorrow. I'm about to crash. I'll let you all hear my results I'm sure lol....

Thanks~
Cheers.

Heretic86

There are two reasons I can think of why either Sensor wont work.

#1  Order of Scripts

If you have another script below either Sensor script that overwrites Event Update method, neither Sensor will trigger a Page Change.

#2  Event Page Configuration

Each Event can have multiple Pages, but on each of those Pages, the Conditions need to be different.  IE, on Page 1, there are No Conditions, but on Page 2, Self Switch D should be checked as a Page Condition.  Thats the simplest form of a Sensor with both scripts.  As an experiment, try putting in different Graphics on each page.  That way you can at least tell that the Event Page changes, then you can move on to Triggers not working.
Current Scripts:
Heretic's Moving Platforms

Current Demos:
Collection of Art and 100% Compatible Scripts

(Script Demos are all still available in the Collection link above.  I lost some individual demos due to a server crash.)

Kiwa

April 17, 2014, 11:41:32 pm #9 Last Edit: April 18, 2014, 12:56:27 am by Kiwa
I've tried absolutely everything I can imagine.. not sure why it wont work.

<Sensor4>
is what i'm using in the name.
I've placed it above BABS under BABS.
I Removed "BlizzABS Battle Music by Nathmatt" in case it was interrupting.
I've changed events to action button, parallel process, autorun.
I've placed Self switch triggers in the event command box and nothing..


I currently have page 1 as a dog.. page 2 is a cat with conditions self switch D checked.
The script says default switch is 'D' so I have no idea why its not working.

If i place a message in the event command box. for page1 i can talk to it by action button.
if i do the same for page2. no such luck.

***EDIT***

I think it disagrees with BABS.
I started a new project with only BABS i was having the same trouble.
I removed BABS and it worked just fine.

Heretic86

Being that this may be related to the nature of BABS, it might be better to ask LittleDrago to create a version of his Sensor script that is intended as an Addon to Blizz-ABS since it doesnt appear to function as expected.
Current Scripts:
Heretic's Moving Platforms

Current Demos:
Collection of Art and 100% Compatible Scripts

(Script Demos are all still available in the Collection link above.  I lost some individual demos due to a server crash.)